Cannot download Polyglot or KingSlayer source code

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Post Reply
User avatar
hgm
Posts: 24617
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: Cannot download Polyglot or KingSlayer source code

Post by hgm » Mon Jan 01, 2018 5:51 pm

There is no official maintainer since Michel van den Bergh gave it up, AFAIK. I never considered myself a maintainer of Polyglot, just a user who needed a version that supported the extensions of WB protocol, so that the new XBoard features would also work with UCI egines.

As far as XBoard/WinBoard is concerned, Polyglot is scheduled for retirement anyway. The latest beta package of WinBoard did not contain any Polyglot, but relied on UCI2WB instead.

The Debian maintainer uses my fork, because it is the most advanced version, and taking other versions would cause heavy loss of functionality of XBoard.

User avatar
Ovyron
Posts: 4256
Joined: Tue Jul 03, 2007 2:30 am

Re: Cannot download Polyglot or KingSlayer source code

Post by Ovyron » Mon Jan 01, 2018 6:19 pm

hgm wrote:The latest beta package of WinBoard did not contain any Polyglot, but relied on UCI2WB instead.
Wow, that's surprising. What are the advantages of UCI2WB over Polyglot?

User avatar
hgm
Posts: 24617
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: Cannot download Polyglot or KingSlayer source code

Post by hgm » Mon Jan 01, 2018 6:31 pm

UCI2WB is variant agnostic, and supports all UCI dialects (USI, UCCI, UCI-Cyclone, Arena960). Polyglot is useless for anything other than ordinary Chess.

Post Reply