Pi Zero compiling XBoard

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Richard Allbert
Posts: 767
Joined: Wed Jul 19, 2006 7:58 am

Pi Zero compiling XBoard

Post by Richard Allbert » Sat Feb 06, 2016 2:11 pm

Hi people

My engine is running fine on a raspberry pi zero (which btw is an amazng piece of kit for its size :))

I'd like to run it on the ICC with the pi zero (I hope Xboard + Zippy works in console mode...)

I've been installing the packages needed for compiling XBoard.

I've hit a stumbling block with
Xt headers not found. Please install the X11 packages
Googling has led to lots of different suggestions... does anyone know what I need to install?

Any help appreciated.

User avatar
hgm
Posts: 23723
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: Pi Zero compiling XBoard

Post by hgm » Sat Feb 06, 2016 2:29 pm

There are two ways to build XBoard: using the archaic Athena widget set (Xaw) or using GTK2+. Each of those will require the developer package for the corresponding widget set, and to run the result you would need the run-time libraries. The error message sounds like you are trying to build the Xaw version, but don't have the headers for libXaw installed.

Richard Allbert
Posts: 767
Joined: Wed Jul 19, 2006 7:58 am

Re: Pi Zero compiling XBoard

Post by Richard Allbert » Sat Feb 06, 2016 4:11 pm

Ok, thanks HG :).

I didn't choose the old version on purpose - I just went as directed in the Winboard forum to the link http://ftp.gnu.org/gnu/xboard/ - downloaded the 4.8.0 tar and followed the install file instructions (./configure, make, make check, make install)

Is there a different location for the GTK version? Or have I missed something :) ?

Thanks for your help!!

Also Console Mode + Zippy - does that work ok ( iirc there's a noGui flag or similar)

[Edit: Installing gtk 2, which is taking a while.. :)]

User avatar
hgm
Posts: 23723
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: Pi Zero compiling XBoard

Post by hgm » Sat Feb 06, 2016 6:04 pm

You can select it with a ./configure flag:

./configure --with-gtk

XBoard uses the console from which it starts as ICS interaction window, so you should have no problems running that way even if you want to give ICS commands (rather than just having it wait passively until it is challenged).

bnemias
Posts: 373
Joined: Thu Aug 14, 2008 1:21 am
Location: Albuquerque, NM

Re: Pi Zero compiling XBoard

Post by bnemias » Sun Feb 07, 2016 2:36 am

Richard Allbert wrote:Ok, thanks HG :).
Also Console Mode + Zippy - does that work ok ( iirc there's a noGui flag or similar)
I recommend http://sourceforge.net/projects/icsdrone/ for running engines. It has a very nice proxy feature which allows you to connect xboard (or other GUI) when needed.

The advantage of running this way is it is headless until you decide to connect a GUI, and importantly, that GUI need not be on the same machine. Meaning, you can run the engine on a headless server with no GUI capabilities at all, and connect to your running engine from some other machine with GUI facilities. Windows, linux, whatever.

I have only tested this using xboard and winboard, but it makes administering a computer account very easy.

For example, when I want to check out one of my bots:

Code: Select all

rlwrap xboard -ics -icshost <engine lan address>
or on the local machine:

Code: Select all

rlwrap xboard -ics -icshost localhost

Richard Allbert
Posts: 767
Joined: Wed Jul 19, 2006 7:58 am

Re: Pi Zero compiling XBoard

Post by Richard Allbert » Sun Feb 07, 2016 6:27 am

Hi Eric,

Thanks, I''l have a look at that today :)

@HG thanks for the config, getting ready to set it up now.

Richard Allbert
Posts: 767
Joined: Wed Jul 19, 2006 7:58 am

Re: Pi Zero compiling XBoard

Post by Richard Allbert » Sun Feb 07, 2016 1:29 pm

Just following up, all is working ok.

Is there a guide for compiling polyglot? Am I supposed to take a snapshort from here:

http://hgm.nubati.net/cgi-bin/gitweb.cg ... ;a=summary

?

I did, but had a whole host of errors compiling (configure was ok).

bnemias
Posts: 373
Joined: Thu Aug 14, 2008 1:21 am
Location: Albuquerque, NM

Re: Pi Zero compiling XBoard

Post by bnemias » Sun Feb 07, 2016 3:41 pm

That should work, what were the errors?

I use this, but looks like it should be the same as master.
http://hardy.uhasselt.be/Toga/polyglot- ... 70b.tar.gz

bnemias
Posts: 373
Joined: Thu Aug 14, 2008 1:21 am
Location: Albuquerque, NM

Re: Pi Zero compiling XBoard

Post by bnemias » Sun Feb 07, 2016 4:05 pm

Ok, I tried the git master snapshot and it failed. Only got 2 errors, but clearly it is different. Try the link I provided, should work fine.

Richard Allbert
Posts: 767
Joined: Wed Jul 19, 2006 7:58 am

Re: Pi Zero compiling XBoard

Post by Richard Allbert » Sun Feb 07, 2016 4:52 pm

bnemias wrote:Ok, I tried the git master snapshot and it failed. Only got 2 errors, but clearly it is different. Try the link I provided, should work fine.
Ok, I will thanks :)

Although the engine also uses the xboard protocol anyway so there's probably no need. :)

Post Reply