Problems with cutechess-cli in Mavericks (OSX 10.9)

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Post Reply
mvk
Posts: 589
Joined: Tue Jun 04, 2013 8:15 pm

Problems with cutechess-cli in Mavericks (OSX 10.9)

Post by mvk » Thu Nov 21, 2013 10:10 pm

After upgrading to ‘Mavericks’ OSX 10.9 I can’t run cutechess-cli anymore.
See below for the error message.

Are others experiencing the same problem?

Note that in the upgrade process I did uninstall and reinstall the complete macports tree, as nothing in there was working there anymore as well. I don't have issues with macports programs.

Code: Select all

marcelk@beobook3:~/Projects/rookie/Shootout> cutechess-cli/cutechess-cli.sh
dyld: Library not loaded: QtCore.framework/Versions/4/QtCore
  Referenced from: /Users/marcelk/Projects/rookie/Shootout/cutechess-cli/cutechess-cli
  Reason: image not found
cutechess-cli/cutechess-cli.sh: line 13: 97960 Trace/BPT trap: 5       $dirname/$appname "$@"
133-marcelk@beobook3:~/Projects/rookie/Shootout> uname -a
Darwin beobook3 13.0.0 Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64

User avatar
lucasart
Posts: 3037
Joined: Mon May 31, 2010 11:29 am
Full name: lucasart
Contact:

Re: Problems with cutechess-cli in Mavericks (OSX 10.9)

Post by lucasart » Thu Nov 21, 2013 11:17 pm

Try to make static compiles of cutechess:

Code: Select all

qmake -config static && make
Theory and practice sometimes clash. And when that happens, theory loses. Every single time.

zullil
Posts: 5607
Joined: Mon Jan 08, 2007 11:31 pm
Location: PA USA
Full name: Louis Zulli

Re: Problems with cutechess-cli in Mavericks (OSX 10.9)

Post by zullil » Fri Nov 22, 2013 12:48 am

mvk wrote:After upgrading to ‘Mavericks’ OSX 10.9 I can’t run cutechess-cli anymore.
See below for the error message.

Are others experiencing the same problem?

Note that in the upgrade process I did uninstall and reinstall the complete macports tree, as nothing in there was working there anymore as well. I don't have issues with macports programs.

Code: Select all

marcelk@beobook3:~/Projects/rookie/Shootout> cutechess-cli/cutechess-cli.sh
dyld: Library not loaded: QtCore.framework/Versions/4/QtCore
  Referenced from: /Users/marcelk/Projects/rookie/Shootout/cutechess-cli/cutechess-cli
  Reason: image not found
cutechess-cli/cutechess-cli.sh: line 13: 97960 Trace/BPT trap: 5       $dirname/$appname "$@"
133-marcelk@beobook3:~/Projects/rookie/Shootout> uname -a
Darwin beobook3 13.0.0 Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
I'm still on Lion.

Do you have an executable called QtCore in /opt/local/Library/Frameworks/QtCore.framework/Versions/4 ?

Your cutechess-cli is dynamically linked with that executable, and it's not being located.

mvk
Posts: 589
Joined: Tue Jun 04, 2013 8:15 pm

Re: Problems with cutechess-cli in Mavericks (OSX 10.9)

Post by mvk » Fri Nov 22, 2013 8:54 am

zullil wrote:[
I'm still on Lion.

Do you have an executable called QtCore in /opt/local/Library/Frameworks/QtCore.framework/Versions/4 ?

Your cutechess-cli is dynamically linked with that executable, and it's not being located.
Interesting, QtCore.framework is completely missing.

I tried to install it, but now macports complains:

Code: Select all

marcelk@beobook3:/opt/local/Library/Frameworks> ls
AquaTerm.framework/	Python.framework/	wxWidgets.framework/
marcelk@beobook3:/opt/local/Library/Frameworks> sudo port install qt4-mac

[... snip ...]

--->  Configuring qt4-mac
Error: org.macports.configure for port qt4-mac returned: incomplete operator "="
in expression "${MINOR} = "9""
Please see the log file for port qt4-mac for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt4-mac/qt4-mac/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qt4-mac failed 
main.log doesn't make me any wiser:

Code: Select all

:notice:configure --->  Configuring qt4-mac
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing proc-pre-org.macports.configure-configure-0
:error:configure org.macports.configure for port qt4-mac returned: incomplete operator "="
in expression "${MINOR} = "9""
:debug:configure Error code: NONE
:debug:configure Backtrace: incomplete operator "="
in expression "${MINOR} = "9""
    while executing
"$pre $targetname"
:info:configure Warning: targets not executed for qt4-mac: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Please see the log file for port qt4-mac for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt4-mac/qt4-mac/main.log
I don't fully understand why cutechess-cli needs Qt in the first place. Obviously, I'm not a golfer.

mvk
Posts: 589
Joined: Tue Jun 04, 2013 8:15 pm

Re: Problems with cutechess-cli in Mavericks (OSX 10.9)

Post by mvk » Fri Nov 22, 2013 9:36 am

I got a little help from http://trac.macports.org/ticket/40852.

Code: Select all

1-marcelk@beobook3:/opt/local/Library/Frameworks> sudo port selfupdate
Password:
--->  Updating MacPorts base sources using rsync
MacPorts base version 2.2.1 installed,
MacPorts base version 2.2.1 downloaded.
--->  Updating the ports tree
--->  MacPorts base is already the latest version

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
marcelk@beobook3:/opt/local/Library/Frameworks> sudo port clean qt4-mac
--->  Cleaning qt4-mac
marcelk@beobook3:/opt/local/Library/Frameworks> sudo port install qt4-mac

[... snip and have some coffee ...]

--->  Cleaning qt4-mac
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

marcelk@beobook3:/opt/local/Library/Frameworks> ls
AquaTerm.framework/		QtDeclarative.framework/	QtNetwork.framework/		QtTest.framework/
Python.framework/		QtDesigner.framework/		QtOpenGL.framework/		QtUiTools.framework/
Qt3Support.framework/		QtDesignerComponents.framework/	QtScript.framework/		QtWebKit.framework/
QtCLucene.framework/		QtGui.framework/		QtScriptTools.framework/	QtXml.framework/
QtCore.framework/		QtHelp.framework/		QtSql.framework/		QtXmlPatterns.framework/
QtDBus.framework/		QtMultimedia.framework/		QtSvg.framework/		wxWidgets.framework/
But after that, still the original cutechess-cli errors. Strange thing is, all of Qt is there and also QtCore.framework/Versions/4/. Loving it. Next I'll try is delete cutechess-cli and reinstall that from scratch.

Post Reply