cutechess 64-bit linux compile

Discussion of anything and everything relating to chess playing software and machines.

Moderators: hgm, Harvey Williamson, bob

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Post Reply
arturo100
Posts: 53
Joined: Thu Jun 25, 2009 8:34 am

cutechess 64-bit linux compile

Post by arturo100 » Mon May 13, 2013 9:24 am

I would like to use cutechess-cli (command line interface) on a computer cluster to run a few matches among several engines starting from a given fen position. Unfortunately, I don't have root permission to install the qmake command needed for compilation. 64 bit linux compiles are indeed available, but they stop at version 0.5.1, which doesn't support the start from a fen string. I was wondering if anyone could post a compile of the lasest version of the program for download.
Thanks in advance.

Arturo

User avatar
ilari
Posts: 750
Joined: Mon Mar 27, 2006 5:45 pm
Location: Finland
Contact:

Re: cutechess 64-bit linux compile

Post by ilari » Mon May 13, 2013 4:49 pm

If by "starting from a given fen position" you mean EPD support, then yes, the latest (unreleased) cutechess-cli has it. I made fresh compiles for the Stockfish team and uploaded them to http://koti.mbnet.fi/~ilaripih/bin/
The versions labeled "sf" are up to date with some new features, even if the version number says "0.5.1-SF".

arturo100
Posts: 53
Joined: Thu Jun 25, 2009 8:34 am

Re: cutechess 64-bit linux compile

Post by arturo100 » Mon May 13, 2013 6:19 pm

ilari wrote:If by "starting from a given fen position" you mean EPD support, then yes, the latest (unreleased) cutechess-cli has it. I made fresh compiles for the Stockfish team and uploaded them to http://koti.mbnet.fi/~ilaripih/bin/
The versions labeled "sf" are up to date with some new features, even if the version number says "0.5.1-SF".


Many thanks for the upload. However, I tried to tun it and I got the following errors. The binary compile at github instead ran smoothly.
Thanks again.
Arturo.

-bash-4.1$ ./cutechess-cli
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./cutechess-cli)
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/arturo/cutechess-cli/libQtCore.so.4)
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/arturo/cutechess-cli/libQtCore.so.4)

User avatar
ilari
Posts: 750
Joined: Mon Mar 27, 2006 5:45 pm
Location: Finland
Contact:

Re: cutechess 64-bit linux compile

Post by ilari » Mon May 13, 2013 6:46 pm

The latest binaries were compiled on a newer system so they also require a newer version of GLIBC. The solution is to compile cutechess-cli again on a older OS version, but I don't have anything older than Ubuntu 12.10 installed.

gladius
Posts: 538
Joined: Tue Dec 12, 2006 9:10 am

Re: cutechess 64-bit linux compile

Post by gladius » Mon May 13, 2013 7:17 pm

arturo100 wrote:
ilari wrote:If by "starting from a given fen position" you mean EPD support, then yes, the latest (unreleased) cutechess-cli has it. I made fresh compiles for the Stockfish team and uploaded them to http://koti.mbnet.fi/~ilaripih/bin/
The versions labeled "sf" are up to date with some new features, even if the version number says "0.5.1-SF".


Many thanks for the upload. However, I tried to tun it and I got the following errors. The binary compile at github instead ran smoothly.
Thanks again.
Arturo.

-bash-4.1$ ./cutechess-cli
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./cutechess-cli)
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/arturo/cutechess-cli/libQtCore.so.4)
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/arturo/cutechess-cli/libQtCore.so.4)
The 64 bit version we are using for SF testing is here (compiled with an older glibc): https://github.com/mcostalba/FishCookin ... -64bit.zip

arturo100
Posts: 53
Joined: Thu Jun 25, 2009 8:34 am

Re: cutechess 64-bit linux compile

Post by arturo100 » Tue May 14, 2013 8:43 am

Many thanks to Ilary and Gary for the tips. I tried the stockfish compile of cutechess and it worked fine. Just one more question: I would like to run a match without switching colors (i.e, I would like Houdini to be always black). Is there a way I can do that in cutechess?

Thanks again.

Arturo


gladius wrote:
arturo100 wrote:
ilari wrote:If by "starting from a given fen position" you mean EPD sup port, then yes, the latest (unreleased) cutechess-cli has it. I made fresh compiles for the Stockfish team and uploaded them to http://koti.mbnet.fi/~ilaripih/bin/
The versions labeled "sf" are up to date with some new features, even if the version number says "0.5.1-SF".


Many thanks for the upload. However, I tried to tun it and I got the following errors. The binary compile at github instead ran smoothly.
Thanks again.
Arturo.

-bash-4.1$ ./cutechess-cli
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./cutechess-cli)
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/arturo/cutechess-cli/libQtCore.so.4)
./cutechess-cli: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/arturo/cutechess-cli/libQtCore.so.4)
The 64 bit version we are using for SF testing is here (compiled with an older glibc): https://github.com/mcostalba/FishCookin ... -64bit.zip

Post Reply