XBoard / WinBoard 4.6.0 released

Discussion of anything and everything relating to chess playing software and machines.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Post Reply
User avatar
hgm
Posts: 23718
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

XBoard / WinBoard 4.6.0 released

Post by hgm » Sun Mar 11, 2012 10:32 pm

The long-awaited official release of XBoard 4.6.0 (formerly available as beta version under the name 4.5TM) has finally taken place! The sources are available from the GNU Savannah website as tar ball from their download section.

I prepared a binary installer for WinBoard; for those who want to test it: it is already available from http://hgm.nubati.net/WinBoard-4.6.0.exe . Tomorrow I will create a page for it in the download section of WinBoard forum.

For those that are still using 4.5.3, and have not experimented with the TM version: there is a page listing and explaining the new features at the GNU website, http://www.gnu.org/software/xboard/what ... ortal.html .

Also new is that we now have an on-line user guide for XBoard (but WinBoard would be practically the same, except for the screenshots), summarizing its most-important features: http://www.gnu.org/software/xboard/user ... Guide.html

Dirt
Posts: 2851
Joined: Wed Mar 08, 2006 9:01 pm
Location: Irvine, CA, USA

Re: XBoard / WinBoard 4.6.0 released

Post by Dirt » Mon Mar 12, 2012 2:38 am

Trying to figure out just where to download xboard from was not so easy. I finally found it here. I'll try and compile it later.

User avatar
hgm
Posts: 23718
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: XBoard / WinBoard 4.6.0 released

Post by hgm » Mon Mar 12, 2012 6:45 am

Indeed, this is their master downoad page. They do request you to use mirrors, however:

http://www.gnu.org/software/xboard/#download

I don't know how seriously that should be taken.

User avatar
JuLieN
Posts: 2948
Joined: Mon May 05, 2008 10:16 am
Location: Nantes (France)
Contact:

Re: XBoard / WinBoard 4.6.0 released

Post by JuLieN » Mon Mar 12, 2012 6:52 am

Thanks H.G.! :D

Here is my OSX Compile:
http://julien.marcel.free.fr/macchess/xboard-4.6.0.zip

It compiled without a single warning!

As it needs X11 maybe it won't work on Mountain Lion (not tested), but it works perfectly on Lion, here.
"The only good bug is a dead bug." (Don Dailey)
Image [Blog: http://tinyurl.com/predateur ] [Facebook: http://tinyurl.com/fbpredateur ] [MacEngines: http://tinyurl.com/macengines ]

zullil
Posts: 5668
Joined: Mon Jan 08, 2007 11:31 pm
Location: PA USA
Full name: Louis Zulli

Re: XBoard / WinBoard 4.6.0 released

Post by zullil » Mon Mar 12, 2012 11:20 am

JuLieN wrote:Thanks H.G.! :D

Here is my OSX Compile:
http://julien.marcel.free.fr/macchess/xboard-4.6.0.zip

It compiled without a single warning!

As it needs X11 maybe it won't work on Mountain Lion (not tested), but it works perfectly on Lion, here.
Your binary links with the following X11 libraries, which will not be provided with Mountain Lion (as far as I understand):

Code: Select all

	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 159.1.0)
	/usr/X11/lib/libXaw.7.dylib (compatibility version 8.0.0, current version 8.0.0)
	/usr/X11/lib/libXpm.4.dylib (compatibility version 16.0.0, current version 16.0.0)
	/usr/X11/lib/libSM.6.dylib (compatibility version 7.0.0, current version 7.1.0)
	/usr/X11/lib/libICE.6.dylib (compatibility version 10.0.0, current version 10.0.0)
	/usr/X11/lib/libXmu.6.dylib (compatibility version 9.0.0, current version 9.0.0)
	/usr/X11/lib/libX11.6.dylib (compatibility version 10.0.0, current version 10.0.0)
	/usr/X11/lib/libXt.6.dylib (compatibility version 7.0.0, current version 7.0.0)
A better X11 installation for OS X, which has been available for several years, and which already supports 10.8, is XQuartz. Currently, XQuartz uses /opt/X11/lib, to avoid conflict with Apple-supplied libraries.

In general, it seems a bad idea to me to distribute "naked binaries" of projects like XBoard. For those who can't build and install on their own, a good option is to use a port management system like MacPorts. (Unfortunately, their version of XBoard is 4.4.3; I've put in an update request.)

[EDIT---Doesn't XBoard need bitmaps and other data to run? Will your binary work without these? :shock: ]

zullil
Posts: 5668
Joined: Mon Jan 08, 2007 11:31 pm
Location: PA USA
Full name: Louis Zulli

Re: XBoard / WinBoard 4.6.0 released

Post by zullil » Mon Mar 12, 2012 11:41 am

Too late too edit my previous post again, but I realize now that the data is in the source directory, which you have distributed.

zullil
Posts: 5668
Joined: Mon Jan 08, 2007 11:31 pm
Location: PA USA
Full name: Louis Zulli

Re: XBoard / WinBoard 4.6.0 released

Post by zullil » Mon Mar 12, 2012 11:48 am

Would it be possible to include fairymax with XBoard, so that engine would be installed at the same time? Otherwise there's an error the first time a user starts XBoard, because the default .conf file contains

Code: Select all

;
; Engines & adjudicatons in engine-engine games
;
-firstChessProgram fairymax
-secondChessProgram fairymax

User avatar
JuLieN
Posts: 2948
Joined: Mon May 05, 2008 10:16 am
Location: Nantes (France)
Contact:

Re: XBoard / WinBoard 4.6.0 released

Post by JuLieN » Mon Mar 12, 2012 11:53 am

zullil wrote:Would it be possible to include fairymax with XBoard, so that engine would be installed at the same time? Otherwise there's an error the first time a user starts XBoard, because the default .conf file contains

Code: Select all

;
; Engines & adjudicatons in engine-engine games
;
-firstChessProgram fairymax
-secondChessProgram fairymax
Ok, I'll repost my build package later today :) Have you been able to add engines to Xboard? I couldn't: got crashes each time (seg fault).
"The only good bug is a dead bug." (Don Dailey)
Image [Blog: http://tinyurl.com/predateur ] [Facebook: http://tinyurl.com/fbpredateur ] [MacEngines: http://tinyurl.com/macengines ]

zullil
Posts: 5668
Joined: Mon Jan 08, 2007 11:31 pm
Location: PA USA
Full name: Louis Zulli

Re: XBoard / WinBoard 4.6.0 released

Post by zullil » Mon Mar 12, 2012 12:03 pm

JuLieN wrote:
zullil wrote:Would it be possible to include fairymax with XBoard, so that engine would be installed at the same time? Otherwise there's an error the first time a user starts XBoard, because the default .conf file contains

Code: Select all

;
; Engines & adjudicatons in engine-engine games
;
-firstChessProgram fairymax
-secondChessProgram fairymax
Ok, I'll repost my build package later today :) Have you been able to add engines to Xboard? I couldn't: got crashes each time (seg fault).
My request about fairymax was directed to H.G.Muller. It seems sensible to me to include at least one default engine with the xboard package.

I just compiled and updated my existing xboard; I'll test it a bit later and see if it crashes. It ran perfectly during my quick check.

I built my binary against the X11 libs supplied by XQuartz, which should be newer than the Apple-supplied ones:

Code: Select all

/usr/local/bin/xboard:
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 159.1.0)
	/opt/X11/lib/libXaw.7.dylib (compatibility version 8.0.0, current version 8.0.0)
	/opt/X11/lib/libXpm.4.dylib (compatibility version 16.0.0, current version 16.0.0)
	/opt/X11/lib/libSM.6.dylib (compatibility version 7.0.0, current version 7.1.0)
	/opt/X11/lib/libICE.6.dylib (compatibility version 10.0.0, current version 10.0.0)
	/opt/X11/lib/libXmu.6.dylib (compatibility version 9.0.0, current version 9.0.0)
	/opt/X11/lib/libX11.6.dylib (compatibility version 10.0.0, current version 10.0.0)
	/opt/X11/lib/libXt.6.dylib (compatibility version 7.0.0, current version 7.0.0)
[EDIT] --- I added an engine using the browser built into XBoard. No crashes.

User avatar
hgm
Posts: 23718
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: XBoard / WinBoard 4.6.0 released

Post by hgm » Mon Mar 12, 2012 12:48 pm

DarkLord42 usually builds binary packages of XBoard for Mac, with engines, polyglot, timeseal and lots of other stuff included and pre-installed, in a way comparable to how WinBoard is distributed. These packages are available from WinBoard forum. We haven't allowed him any time to do this on 4.6.0, though: I put the request to him by PM only this morning.

Note that XBoard doesn't really need external data: the piece pixmaps are all built in. To use it in its full glory, however, we supply it (on "make install") with a master settings file that configures it to use external pixmaps for the board texture. New in this version is that we also supply a lot of "desktop stuff": a proper install will define mime types for .fen, .pgn and .trn file, install icons for the latter two, and defines XBoard as handler for them, with applicable options. So that when you double-click a PGN file, XBoard will start up in game-viewer mode with the PGN loaded, etc.

As to bundling XBoard with an engine: this is not really the Linux way for distributing software. There really should be a dependency of the xboard package on fairymax (and polyglot). Unfortunately, Debian policy is a bit ineffective in this respect. They insist that XBoard is not dependent on fairymax (and before, not on gnuchess) because it can be run as "xboard -ics" to connect to FICS without the need for an engine.

Note that this version of XBoard does not crash when the startup engine is not found on the system, but simply switches back to -ncp mode in that case. You will get the error popup, though, but in absence of a better dependency policy, I think that is for the best. Making -ncp the default mode would not be what most people want, and silently switching to -ncp mode would obscure what they have to do to get it working as intended.

Post Reply