Problem using XBoard + Polyglot + Zippy on FICS

Discussion of chess software programming and technical issues.

Moderators: bob, hgm, Harvey Williamson

Forum rules
This textbox is used to restore diagrams posted with the [d] tag before the upgrade.
Post Reply
bhlangonijr
Posts: 482
Joined: Thu Oct 16, 2008 2:23 am
Location: Milky Way
Contact:

Problem using XBoard + Polyglot + Zippy on FICS

Post by bhlangonijr » Mon Nov 15, 2010 11:12 pm

Hello all,

Everytime I play with my engine on FICS server and the opponent sends a castle move I get the error "Couldn't parse move 'O-O' from ICS" and my engine keep pondering 'forever'. If I disconnect from FICS and connect again the game is resumed from that point and everything works fine.

I am playing with the command bellow:

Code: Select all

xboard -fUCI -fcp /opt/projects/redqueen/Release/redqueen -polyglotBook /opt/book/redqueen.bin -size mediocre -firstHasOwnBookUCI false -usePolyglotBook true -showThinking true -defaultHashSize 256 -autoKibitz -zp -ics -icshost freechess.org  -saveGameFile /opt/chess/fics.pgn
I am using Fedora 12 and XBoard 4.4.4. Has anyone ever experienced this problem?
Any help would be appreciated.

Thanks,

User avatar
michiguel
Posts: 6389
Joined: Thu Mar 09, 2006 7:30 pm
Location: Chicago, Illinois, USA
Contact:

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by michiguel » Mon Nov 15, 2010 11:21 pm

bhlangonijr wrote:Hello all,

Everytime I play with my engine on FICS server and the opponent sends a castle move I get the error "Couldn't parse move 'O-O' from ICS" and my engine keep pondering 'forever'. If I disconnect from FICS and connect again the game is resumed from that point and everything works fine.

I am playing with the command bellow:

Code: Select all

xboard -fUCI -fcp /opt/projects/redqueen/Release/redqueen -polyglotBook /opt/book/redqueen.bin -size mediocre -firstHasOwnBookUCI false -usePolyglotBook true -showThinking true -defaultHashSize 256 -autoKibitz -zp -ics -icshost freechess.org  -saveGameFile /opt/chess/fics.pgn
I am unsing Fedora 12 and XBoard 4.4.4. Has anyone ever experienced this problem?
Any help would be appreciated.

Thanks,
I played many games in FICS without problems.
I am using version "master-20100327"
Have you tried other xboard versions? This is really odd.

Miguel

bhlangonijr
Posts: 482
Joined: Thu Oct 16, 2008 2:23 am
Location: Milky Way
Contact:

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by bhlangonijr » Mon Nov 15, 2010 11:33 pm

michiguel wrote:
bhlangonijr wrote:Hello all,

Everytime I play with my engine on FICS server and the opponent sends a castle move I get the error "Couldn't parse move 'O-O' from ICS" and my engine keep pondering 'forever'. If I disconnect from FICS and connect again the game is resumed from that point and everything works fine.

I am playing with the command bellow:

Code: Select all

xboard -fUCI -fcp /opt/projects/redqueen/Release/redqueen -polyglotBook /opt/book/redqueen.bin -size mediocre -firstHasOwnBookUCI false -usePolyglotBook true -showThinking true -defaultHashSize 256 -autoKibitz -zp -ics -icshost freechess.org  -saveGameFile /opt/chess/fics.pgn
I am unsing Fedora 12 and XBoard 4.4.4. Has anyone ever experienced this problem?
Any help would be appreciated.

Thanks,
I played many games in FICS without problems.
I am using version "master-20100327"
Have you tried other xboard versions? This is really odd.

Miguel
Just installed the version you mentioned and get the follow error before XBoard starts:

Code: Select all

StartChildProcess (dir="") polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "."
xboard: Failed to start first chess program polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "." on localhost: Can't open file "polyglot.ini": No such file or directory
Trying to find out what is wrong with polyglot here.

Thanks Miguel,

Michel
Posts: 2057
Joined: Sun Sep 28, 2008 11:50 pm

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by Michel » Mon Nov 15, 2010 11:47 pm

StartChildProcess (dir="") polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "."
xboard: Failed to start first chess program polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "." on localhost: Can't open file "polyglot.ini": No such file or directory
I think it means you have a version of polyglot in your path (I assume this is Linux) which does not understand the -noini syntax. The ones included in recent versions of Debian/Ubunto do. They come from here

http://alpha.uhasselt.be/Research/Algeb ... t-release/

bhlangonijr
Posts: 482
Joined: Thu Oct 16, 2008 2:23 am
Location: Milky Way
Contact:

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by bhlangonijr » Tue Nov 16, 2010 12:07 am

Michel wrote:
StartChildProcess (dir="") polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "."
xboard: Failed to start first chess program polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "." on localhost: Can't open file "polyglot.ini": No such file or directory
I think it means you have a version of polyglot in your path (I assume this is Linux) which does not understand the -noini syntax. The ones included in recent versions of Debian/Ubunto do. They come from here

http://alpha.uhasselt.be/Research/Algeb ... t-release/
Thanks Michel.

Polyglot now is working, but still the same problem happens when playing on FICS:

Image

Michel
Posts: 2057
Joined: Sun Sep 28, 2008 11:50 pm

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by Michel » Tue Nov 16, 2010 8:59 am

This appears to be an xboard issue as it seems the error is coming from xboard and not from polyglot. The PG source does not contain the string "from ICS". So HGM is the person to comment on this.

User avatar
hgm
Posts: 23790
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by hgm » Tue Nov 16, 2010 9:18 am

The message is surely comming from XBoard.
But wild/3 is variant nocastle, not? In the screenshot XBoard says you are playing w3, in the title bar. So it makes kind of sense that it would not accept castling.

If there is a misidentification of the variant here, I would have to see the ICS start-of-game message from the debug file to make a guess as to what could have caused it.

bhlangonijr
Posts: 482
Joined: Thu Oct 16, 2008 2:23 am
Location: Milky Way
Contact:

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by bhlangonijr » Tue Nov 16, 2010 10:55 am

hgm wrote:The message is surely comming from XBoard.
But wild/3 is variant nocastle, not? In the screenshot XBoard says you are playing w3, in the title bar. So it makes kind of sense that it would not accept castling.

If there is a misidentification of the variant here, I would have to see the ICS start-of-game message from the debug file to make a guess as to what could have caused it.
It's weird because I am playing with an UCI engine and using polyglot as adaptor. And AFAIK neither polyglot nor the engine is declaring it is able to play any variant other than the standard chess.

In my opinion if the engine doesn't declare the variants it is able to play, the GUI must assume that it is only able to play normal chess.

Is there any other -better- alternative for playing in FICS using XBoard with UCI engines? Or at least a workaround to get rid of this problem?

User avatar
hgm
Posts: 23790
Joined: Fri Mar 10, 2006 9:06 am
Location: Amsterdam
Full name: H G Muller
Contact:

Re: Problem using XBoard + Polyglot + Zippy on FICS

Post by hgm » Tue Nov 16, 2010 6:02 pm

Nocastle is not really a variant: it is normal Chess from a non-standard position which happens to have no castling rights. So any engine that can play normal Chess can play it.

IMO it would be better to repair it than to start looking for work-arounds...

Post Reply