Page 1 of 1

Problem using XBoard + Polyglot + Zippy on FICS

Posted: Mon Nov 15, 2010 11:12 pm
by bhlangonijr
Hello all,

Everytime I play with my engine on FICS server and the opponent sends a castle move I get the error "Couldn't parse move 'O-O' from ICS" and my engine keep pondering 'forever'. If I disconnect from FICS and connect again the game is resumed from that point and everything works fine.

I am playing with the command bellow:

Code: Select all

xboard -fUCI -fcp /opt/projects/redqueen/Release/redqueen -polyglotBook /opt/book/redqueen.bin -size mediocre -firstHasOwnBookUCI false -usePolyglotBook true -showThinking true -defaultHashSize 256 -autoKibitz -zp -ics -icshost freechess.org  -saveGameFile /opt/chess/fics.pgn
I am using Fedora 12 and XBoard 4.4.4. Has anyone ever experienced this problem?
Any help would be appreciated.

Thanks,

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Mon Nov 15, 2010 11:21 pm
by michiguel
bhlangonijr wrote:Hello all,

Everytime I play with my engine on FICS server and the opponent sends a castle move I get the error "Couldn't parse move 'O-O' from ICS" and my engine keep pondering 'forever'. If I disconnect from FICS and connect again the game is resumed from that point and everything works fine.

I am playing with the command bellow:

Code: Select all

xboard -fUCI -fcp /opt/projects/redqueen/Release/redqueen -polyglotBook /opt/book/redqueen.bin -size mediocre -firstHasOwnBookUCI false -usePolyglotBook true -showThinking true -defaultHashSize 256 -autoKibitz -zp -ics -icshost freechess.org  -saveGameFile /opt/chess/fics.pgn
I am unsing Fedora 12 and XBoard 4.4.4. Has anyone ever experienced this problem?
Any help would be appreciated.

Thanks,
I played many games in FICS without problems.
I am using version "master-20100327"
Have you tried other xboard versions? This is really odd.

Miguel

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Mon Nov 15, 2010 11:33 pm
by bhlangonijr
michiguel wrote:
bhlangonijr wrote:Hello all,

Everytime I play with my engine on FICS server and the opponent sends a castle move I get the error "Couldn't parse move 'O-O' from ICS" and my engine keep pondering 'forever'. If I disconnect from FICS and connect again the game is resumed from that point and everything works fine.

I am playing with the command bellow:

Code: Select all

xboard -fUCI -fcp /opt/projects/redqueen/Release/redqueen -polyglotBook /opt/book/redqueen.bin -size mediocre -firstHasOwnBookUCI false -usePolyglotBook true -showThinking true -defaultHashSize 256 -autoKibitz -zp -ics -icshost freechess.org  -saveGameFile /opt/chess/fics.pgn
I am unsing Fedora 12 and XBoard 4.4.4. Has anyone ever experienced this problem?
Any help would be appreciated.

Thanks,
I played many games in FICS without problems.
I am using version "master-20100327"
Have you tried other xboard versions? This is really odd.

Miguel
Just installed the version you mentioned and get the follow error before XBoard starts:

Code: Select all

StartChildProcess (dir="") polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "."
xboard: Failed to start first chess program polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "." on localhost: Can't open file "polyglot.ini": No such file or directory
Trying to find out what is wrong with polyglot here.

Thanks Miguel,

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Mon Nov 15, 2010 11:47 pm
by Michel
StartChildProcess (dir="") polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "."
xboard: Failed to start first chess program polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "." on localhost: Can't open file "polyglot.ini": No such file or directory
I think it means you have a version of polyglot in your path (I assume this is Linux) which does not understand the -noini syntax. The ones included in recent versions of Debian/Ubunto do. They come from here

http://alpha.uhasselt.be/Research/Algeb ... t-release/

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Tue Nov 16, 2010 12:07 am
by bhlangonijr
Michel wrote:
StartChildProcess (dir="") polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "."
xboard: Failed to start first chess program polyglot -noini -ec "/opt/projects/redqueen/Release/redqueen" -ed "." on localhost: Can't open file "polyglot.ini": No such file or directory
I think it means you have a version of polyglot in your path (I assume this is Linux) which does not understand the -noini syntax. The ones included in recent versions of Debian/Ubunto do. They come from here

http://alpha.uhasselt.be/Research/Algeb ... t-release/
Thanks Michel.

Polyglot now is working, but still the same problem happens when playing on FICS:

Image

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Tue Nov 16, 2010 8:59 am
by Michel
This appears to be an xboard issue as it seems the error is coming from xboard and not from polyglot. The PG source does not contain the string "from ICS". So HGM is the person to comment on this.

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Tue Nov 16, 2010 9:18 am
by hgm
The message is surely comming from XBoard.
But wild/3 is variant nocastle, not? In the screenshot XBoard says you are playing w3, in the title bar. So it makes kind of sense that it would not accept castling.

If there is a misidentification of the variant here, I would have to see the ICS start-of-game message from the debug file to make a guess as to what could have caused it.

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Tue Nov 16, 2010 10:55 am
by bhlangonijr
hgm wrote:The message is surely comming from XBoard.
But wild/3 is variant nocastle, not? In the screenshot XBoard says you are playing w3, in the title bar. So it makes kind of sense that it would not accept castling.

If there is a misidentification of the variant here, I would have to see the ICS start-of-game message from the debug file to make a guess as to what could have caused it.
It's weird because I am playing with an UCI engine and using polyglot as adaptor. And AFAIK neither polyglot nor the engine is declaring it is able to play any variant other than the standard chess.

In my opinion if the engine doesn't declare the variants it is able to play, the GUI must assume that it is only able to play normal chess.

Is there any other -better- alternative for playing in FICS using XBoard with UCI engines? Or at least a workaround to get rid of this problem?

Re: Problem using XBoard + Polyglot + Zippy on FICS

Posted: Tue Nov 16, 2010 6:02 pm
by hgm
Nocastle is not really a variant: it is normal Chess from a non-standard position which happens to have no castling rights. So any engine that can play normal Chess can play it.

IMO it would be better to repair it than to start looking for work-arounds...